Jump to content

Turbine o seu Perfil

Confira a atualização e participe do clube!
Clique e saiba mais

Junte-se ao Clube de Membros VIP

Tenha destaque e diversos benefícios!
Confira Aqui

Acesse nosso Discord

Conheça nossos canais interativos
Confira Aqui
Notícia
  • Adquira já o seu VIP!
Cr4cko

[VISUALG]Entendo a logica de programação

Recommended Posts

Bom, estou criando este tópico com o objetivo de simplificar a famosa LOGICA DE PROGRAMAÇÃO, para realmente os iniciantes. Nada melhor do que introduzir o programador iniciante com a ferramenta mais basica e considerada a mais escrota: Visualg. Saiba que na faculdade, quando você pensa que vai já ter aula de C++ ou C# nas primeiras semanas, pode tirar o cavalinho da chuva, Visualg vai ser seu primeiro material. Enfim, sem enrolaçao:

 

Vamos iniciar o codigo com um simple sistema de operaçao (soma)

 

algoritmo "soma5"
// Função : Somar 5 numeros
// Autor :  Cr4cko
// Data : 16/02/2014
// Para iniciantes da Web Cheats
var
n1,n2,n3,n4,n5 : inteiro
soma : inteiro
inicio
// Seção de Comandos 
escreva("Digite os 5 numeros: ")
leia(n1,n2,n3,n4,n5)
soma <- n1 + n2 + n3 + n4 + n5
escreva("O resultado da soma e: ",soma)
fimalgoritmo

 

Bom, resumindo, eu declarei 6 variáveis: a dos números (n1,n2,n3,n4,n5) e deixei claro que sao apenas números inteiros. E a variável soma, onde vai ser montado a função de somar os números, que também só vai funcionar com números inteiros.

Abaixo, onde tem "escreva" e o que vai aparecer no console, fazendo uma pergunta "Digite os 5 números:". Isso chamamos de Strings, na programação.

O quando você escrever os 5 números, alguma coisa terá que ser feita, para guardar os 5 números na memoria, enfim o "leia" faz isso.

Abaixo, a função da soma sendo montada. O sinal <- e chamado de recebe, ou seja, variável soma recebe n1 + n2 + n3 + n4 + n5.

Depois, para finalizar, ele ira escrever no console, o resultado da soma, por isso apos as strings, tem a variável soma.

 

algoritmo "soma5" e fimalgoritmo são necessários, pois e oq determina o inicio e o fim do programa no visualg. No "soma5" você coloca oq quiser, eu coloquei soma5 para ficar mais organizado.

 

Vou deixar aqui mais um exercicio para fixar mais um pouco na mente de voces, e um codigo que requer um pouco mais de pensamento, mas nada anormal.

 

1) Desenvolva um programa que calcula o perímetro e área de uma circunferência. Lembrando que raio liga um ponto da circunferência ao centro da mesma. Dados:

calcular perimetro: 2πr

calcular area: πr²

π: 3.14

r: raio

 

algoritmo "exercicio1"
// Função : Perimetro e Area Calc
// Autor :  Cr4cko
// Data : 16/02/2014
// Para iniciantes da Web Cheats
var
perimetro, area, raio : real
inicio
// Seção de Comandos 
escreva("Digite o raio: ")
leia(raio)
perimetro <- 2 * 3.14 * raio
area <- 3.14 * (raio ^ 2)
escreva("O valor da area e: ",area, " e o do perimetro e: ",perimetro)
fimalgoritmo

 

As variáveis são reais, devido aos números com virgula e tudo mais. (3,14 = real)

Na parte (raio ^ 2) o sinal ^ significa potencia, ou seja, raio² = raio elevado a 2.

Saiba mais - Operadores: * (multiplicação), / (divisão), div (quociente da divisão), mod (modulo, ou seja, resto da divisão), - (subtração), + (soma)

 

[DOWN]http://www.guanabara.info/logica/Ferramentas/visualgv25.exe[/DOWN]

SCAN

 

Qualquer duvida, sobre operadores, ou o código ou ate mesmo do visualg, poste aqui e eu estarei respondendo!

Abraços

  • Like 1

Share this post


Link to post
Share on other sites

Gostei bastante dos exercícios !

 

Obrigado ae ! Vo pesquisar mais um pouco espero q vc poste mais tutoriais !

 

Abrass vlw


 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...